vue-cli3 使用extend遇到错误

vue-cli3 使用extend遇到错误,具体报错内容: [Vue warn]: You are using the runtime-only build of Vue where the template compiler is not available. Either pre-compile the templates into render functions, or use the compiler-included build....

brew安装的nginx服务启动后无法启动80端口

用brew安装了nginx后,直接使用下面的命令启动以后,其中80端口的配置文件是无法加载的。因为nginx的80端口需要sudo提权启动。...

webpack4 使用 html-webpack-plugin插件报错:compilation.mainTemplate.applyPluginsWaterfall is not a function

webpack升级到了4.0版本了,但是在使用html-webpack-plugin插件时,报错,提示:TypeError: compilation.mainTemplate.applyPluginsWaterfall is not a function...

MAC OSX PHP7.2环境下安装pdo_oci扩展

工作原因,需要使用oracle数据库,从网上找了一圈资料,很多都是下载PDO_OCI-1.0.tgz去编译,当然,他们是在php5.3-5.6环境下进行的。可是php7.2这套路子就不行了,因为7.2的PDO版本太高了,导致即便使用上面的方法编译出来的pdo_oci.so也是无法使用的。经过一番折腾,发现,原来php7.2源码包扩展目录下自带了pdo_oci的源码,直接编译就OK了,害的我走了那么多弯路。说一下具体方法吧...

Mac用RVM更新Ruby

用brew安装npm发生错误,需要升级ruby到2.3以上版本,接下来就要升级ruby,开始想到用brew安装升级,但是考虑到这种软件还是用RVM升级更靠谱一些,下面是步骤...

mysql5.7安全模式下重新修改root密码

mysql老版本在安全模式下修改密码直接修改user表的Password字段即可,可是5.7版的user表没有这个字段。改成了authentication_string字段,修改该字段即可,处理方法如下...

记一次mysql误删除var启动失败的处理方法

今天在处理一台服务器时,误删除了mysql的var目录,导致无法启动,处理方法如下:1、启动mysql时报错 The server quit without updating PID file...

mysqlbinlog 的常见选项

mysqlbinlog常见的选项有以下几个:...

git 常用参数列表

git常用的参数...

Mac OSX 使用 Switch ResX 设置21:9显示器分辨率

公司配置了LG的21:9显示器,但是,直接插上连接线以后,显示1920X1080分辨率,所有元素全部拉伸,确实难看。于是从网上搜索一番,有一个软件可以设置自定义分辨率。参数需要记录一下,因为当时第一次自定义分辨率后频率超出范围,直接黑屏了。...

我关注的博客:Aries 部落